esSJae's Virtualization Blog

Virtualization and other IT topics

Archive for December 12th, 2009

Eyefinity on new ATi video cards requires an active DisplayPort adapter

Posted by essjae on December 12, 2009

Boo!  After listening to the marketing guy from ATi/AMD at the Ready to Launch show I was all set for a new ATi 5870 for Eyefinity.  Of course, the 3rd port needed is a displayport and I’ve only got DVI LCDs.  He specifically mentioned the Startech DisplayPort DVI adapter available at Newegg as an inexpensive solution if you don’t have displayport monitors.  Well, guess what, he was incorrect.  You need a $100+ active displayport adapter to do 3 displays.  So, now I’m stuck with 2 monitors working until I can get an active displayport adapter next week.

I guess that’s what I get for taking technical advice from the marketing guy.  He also mentioned how the AMD Phenom II X4 965 was faster than all the competitor’s CPUs…doing a little benchmark reviews shows that this isn’t accurate either.  My current i7 is on par or faster than the 965 even when not overclocked.

Don’t get me wrong, I love AMD and ATi, I have AMD stock and after six months of random nVidia Nvlddmkm.sys blue-screens with no consistent solution, I am only purchasing ATi cards for my new systems. (I am still using my older nVidia cards in some of my test boxes)

Update:  The actual AMD docs do specifically mention that you need an active DisplayPort  to DVI adapter and the passive can only be used on a 2 monitor system.  I received my active DisplayPort adapter today (1 day late from Amazon) and will be giving it a try tonight.

Posted in Computers, Hardware | Tagged: , , , | 3 Comments »