esSJae's Virtualization Blog

Virtualization and other IT topics

Archive for March 3rd, 2016

3Ware 9650SE with ESXi 5.5

Posted by essjae on March 3, 2016

This is definitely an edge case, but if you’ve got a bunch of old 3Ware 9650SE RAID cards laying around, they will work in ESXi 5.5.  You’ll need to either create a custom ISO or add them via SSH after the install.  Adding them post-install is easier for me than making another custom ISO.

I’ve set up 2 ESXi servers (old x58 chipset MBs I had laying around) to do some clustering.  I picked up 5 9650SE RAID cards off of eBay for $55, including cables, and cobbled together some RAID volumes from the stacks of HDDs I had laying around.

I set up my ESXi boxes with a custom ISO I’d created previously that has the Realtec NIC, Intel NIC, and Intel SATA drivers (that’s another post, or look up ESXi-customizer). I was able to get the cards up and working with minimal issues (after I updated the firmware to the most current version…was a puzzle as a couple cards were updated and just worked, then I got stuck with some others and they wouldn’t work at all until the FW was updated)

I then replaced one of the ESXi boxes with an x79 system and could not get the RAID card to work with the existing drivers I had.  Hours and multiple reboots, driver uploads, I found another driver that works from Avago (direct): http://docs.avagotech.com/docs/12349232

You can find it here: http://www.avagotech.com/ –> Support –> Support Documents and Downloads –> Legacy RAID controllers –> 3ware 9650SE-xxxx –> Search –> Driver –> VMware ESXi 5.0 Update 1 for 9650SE/9690SA

Connect to your ESXi server via SSH (you’ll need to enable this first) and use the command:

localcli software vib install -v /vmfs/volumes/datastore-name/scsi-3w-9xxx-2.27.08.036-1OEM.500.0.0.472560.x86_64.vib

Posted in ESXi, Virtualization, VMWare | Tagged: , , , , , | Leave a Comment »